Kamis, 14 Agustus 2014

Simple Queue sederhana Mikrotik

Buka Winbox, Masukkan ip dan password mikrotik seperti biasa..
Lalu New terminal, lalu tinggal copy dan paste , enter aja :)

Port 80 ( HTTP / Browsing )

/ip firewall mangle add chain=prerouting protocol=tcp dst-port=80 action=mark-connection new-connection-mark=BrowsingCon passthrough=yes comment=Browsing

/ip firewall mangle add chain=prerouting connection-mark=BrowsingCon action=mark-packet new-packet-mark=BrowsingPaket passthrough=no

ICMP ( Ping )

/ip firewall mangle add chain=prerouting protocol=icmp action=mark-connection new-connection-mark=PingStabil passthrough=yes comment=PingStabil
/ip firewall mangle add chain=prerouting protocol=icmp action=mark-packet new-packet-mark=PingPaket passthrough=no

Game Online ( PB dan Lost saga) Sisanya nanti tambahin sendiri :p
LostSaga
/ip firewall mangle add chain=prerouting protocol=tcp dst-port=14009-14012 action=mark-connection new-connection-mark=GameOnline passthrough=yes Comment=Lostsaga-TCP
/ip firewall mangle add chain=prerouting protocol=udp dst-port=14009-14012 action=mark-connection new-connection-mark=GameOnline passthrough=no Comment=Lostsaga-UDP

PointBlank
/ip firewall mangle add chain=prerouting protocol=tcp dst-port=39000-40000 action=mark-connection new-connection-mark=GameOnline passthrough=yes comment=PointBlank-TCP
/ip firewall mangle add chain=prerouting protocol=udp dst-port=40000-40010 action=mark-connection new-connection-mark=GameOnline passthrough=no comment=PointBlank-UDP

/ip firewall mangle add chain=prerouting connection-mark=GameOnline action=mark-packet new-packet-mark=PaketGameOnline comment=GameOnlinePaket

Ngopi dulu gan biar gak ngantuk dengerin celotehan ane yang nubie ini :p

nanti kalo sudah Ter Mangle Dengan baik sekarang kita pergi ke Queue
nah sebelum kita lebih jauh ke queue ane mau jelasin soal Max Limit dan Limit At
Max limit = Batas Bandwidth Maksimum yang Client bisa dapatkan dari hasil pembagian Bandwidth yang tidak terpakai..
Limit At = Batas Bandwidth Maksimum yang Client bisa dapatkan ketika Bandwidth Full atau Overload

Contoh Kasus =
Agan punya warnet Bandwidth nya 1 Mbps Berisi 10 Komputer..
Nah dalam Queue di setting Max-Limit 256k Limit-At=102

Max-Limit
Pada hari senin Client sepi dan hanya ada 4 PC yang menyala..
Karena agan Setting Max limit 256k , ke 4 PC tersebut mendapatkan Up to 256k Bandwidth.
Kenapa? Karena Bandwitdh yang tidak terpakai akan di bagi rata.. jadi kalau Bandwidth Sedang kosong, Client tersebut di izinkan untuk melewati batas Limit-At
( ibarat jalanan kalau kosong nih, mobil mobil yang melintasi jalan pada nyosor ke ruas jalan yang masih luas , tetapi tetap patuh pada aturan yang ada (Baca:Limit-At)).

Beda kasus dengan Limit-At..
Pada hari selasa Client Ramai dan semua PC terpakai alias 10 PC menyala..
Karena Agan Setting Limit-At 102k, ke 10 PC tersebut mendapatkan 102k Bandwidth
Kenapa ? Karena sudah tidak ada Bandwidth yang kosong jadi berjalan pada Value yang sudah ditetapkan/Limit-At ( ibarat jalanan nih ya, nah saat ini dalam keadaan macet jadi mobil mobil hanya bisa berjalan lurus pada jalur nya, gak di perbolehkan melewati ruas ruas jalan , Kenapa? ya karena Macet sudah banyak mobil mobil lain yang melintas ) .

Untuk Lebih jelas nya ke : http://www.mikrotik.co.id/artikel_lihat.php?id=29

Sekarang Lanjut ke Queue yaa.. Cihuuuy sebentar lagi nih selesai tutorial mini nya :p
Pada kali ini saya implementasikan pada Simple Queue

Kita buat dulu Browsing Parent nya ya anak anak.. Iyaaa paaak *Loh?*

/queue simple add name=Browsing interface=all parent=none priority=8 queue=default/default max-limit=0/1M total-queue=default disabled=no packet-marks=BrowsingPaket

Sekarang kita Buat Turunan nya..
/queue simple add name=PC-1 target-addresses=192.168.1.11 interface=all parent=Browsing priority=8 queue=default/default limit-at=0/102k max-limit=0/256k total-queue=default disabled=no
/queue simple add name=PC-2 target-addresses=192.168.1.12 interface=all parent=Browsing priority=8 queue=default/default limit-at=0/102k max-limit=0/256k total-queue=default disabled=no
/queue simple add name=PC-3 target-addresses=192.168.1.13 interface=all parent=Browsing priority=8 queue=default/default limit-at=0/102k max-limit=0/256k total-queue=default disabled=no
/queue simple add name=PC-4 target-addresses=192.168.1.14 interface=all parent=Browsing priority=8 queue=default/default limit-at=0/102k max-limit=0/256k total-queue=default disabled=no

Ane buat cuma 4 client, sisa nya buat PR ya anak anak :p

Game Online

/queue simple add name="Game Online Stabil" interface=all parent=none priority=1 queue=default/default max-limit=0/0 total-queue=default disabled=no packet-marks=PaketGameOnline

PING

/queue simple add name="Ping Stabil" interface=all parent=none priority=2 queue=default/default max-limit=0/0 total-queue=default disabled=no packet-marks=PingPaket

Nah ane juga mau jelasin soal Priority kan disitu ada yang 1 ada 2 ada yang 8 Bingung kan?
Priority ini maksud nya adalah Bandwidth yang di prioritasin terlebih dahulu.. pokok nya dia selalu barisan depan kalau di set 1, dan akan menjadi barisan belakang kalau di set 8.. setahu ane di mikrotik Priority ada 1 sampai 8 CMIIW
Jadi Game Online ane prioritasin nomor 1 agar gak lag dan terganggu sama yang browsingan..
Ping nomor 2 sesudah Game Online..
Dan Browsing nomor 8 alias Paling belakang..
Ini berlaku untuk yang menggunakan 1 Line.. kalau pakai 2 Line beda lagi.. di Next Tutorial aja Soal 2 line atau berapapun itu hehe..

Naaah akhirnya Mangle Dan Queue selesai juga nih :3

Note :
- Port game Online nya bisa agan tambahin sendiri.. dapet dari mana gan? Google!
- Value Limit At dan Max limit jangan lupa di sesuaikan dengan Bandwidth agan agan.. :)
- Kalau ada istilah ada yang tidak mengerti misalnya seperti Packet mark/Connection mark semua materi ada di Google atau bisa ubek2 langsung di Situs nya Mikrotik.. Bahasa inggris? tapi gak bisa bahasa inggris? saran pertama, Belajar saran kedua Gunakan fasilitas Google Translate :)
- Semua yang saya tulis di atas berdasarkan Apa yang saya pelajari dan pengalaman saya, Jika ada salah salah jangan segan segan untuk Membenarkan, Dengan catatan Diberi Bukti+Alasan yang logis, bukan Berdasarkan 'Kata Orang'

Artikel Terkait

Simple Queue sederhana Mikrotik
4/ 5
Oleh

Berlangganan

Suka dengan artikel di atas? Silakan berlangganan gratis via email